Bug 21 - Doxygen documentation: some image links are broken
: Doxygen documentation: some image links are broken
Status: CLOSED FIXED
Product: Atmel Software Framework
documentation
: v2.0.x
: Other Standalone
: normal priority normal (vote)
: 2.4.0
Assigned To: ASF Maintainers
: http://asf.atmel.no/avr32/services/us...
: knownissue
:
: 412
  Show dependency treegraph
 
Reported: 2010-09-21 16:14 CEST by Hunter
Modified: 2011-04-11 09:55 CEST (History)
2 users (show)

See Also:
Public Description:
Some pictures are missing from from the on-line Doxygen documentation.
Development Branch:
Whiteboard:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hunter 2010-09-21 16:14:24 CEST
Title says it all - links to pictures on this page fail to load:
http://asf.atmel.no/avr32/services/usb/_asf_v1/class/hid/examples/hid_example_freertos/at32uc3b0256_evk1101/doc/html/
Comment 1 Hans-Christian Egtvedt 2010-09-22 19:33:05 CEST
(In reply to comment #0)
> Title says it all - links to pictures on this page fail to load:
> http://asf.atmel.no/avr32/services/usb/_asf_v1/class/hid/examples/hid_example_freertos/at32uc3b0256_evk1101/doc/html/

Thanks for the notice, it is a bug related to how the release scripts do the
final job. The docsrc/ directories are not distributed in the v2.0.0 release,
and it seems like the Doxygen documentation was built after the docsrc/
directories were removed from the tree. It should have been the other way
around...

We'll make sure it is in order for the next release.

Let me know if it is vital to get them fixed in the current on-line version.
Comment 2 Hunter 2010-09-22 19:48:53 CEST
Not critical, just annoying.

It's compounded by the fact that the downloadable zip file has lots of bad
links, missing links, and readme files that don't exist when they should
(services -> audio)... maybe due to what you were saying though.

Docs need some TLC.
Comment 3 Christian Naess 2011-03-22 09:18:25 CET
Some source/header files got an '\image' tag in the doxygen documentation.
These images was missing from the generated documentation because
IMAGE_PATH was not set in the automatically generated doxyfile.doxygen.

Caused by IMAGE_PATH being overseen when we removed manually created
doxyfile.doxygen and started generating these automatically.

Actions taken:
- Added new build type 'doxygen-image-path'
- Changed doxyfile.doxygen template to make IMAGE_PATH dynamic
- Changed doxygen script to get new build type and adding these paths to
IMAGE_PATH

Fixed in SVN revision #15708 in
http://norsvn01.norway.atmel.com/apps/appsavr/avr4000_asf_2/branches/main-dev

Test build report:
http://ssg-0.norway.atmel.com:9000/builders/archive-doc/builds/131
Comment 4 Christian Naess 2011-03-22 09:18:53 CET
*** Bug 352 has been marked as a duplicate of this bug. ***
Comment 5 Jon Anders Haugum 2011-03-24 13:00:29 CET
Reviewed by: Jon Anders Haugum
Comment 6 Christian Naess 2011-04-08 10:31:05 CEST
This bug has been merged to branch dev_mega.
Comment 7 Xavier Leprévost 2011-04-09 11:38:17 CEST
Close the bug, 

One regression found (See Bug 497):
job
http://norvm-tools-m.norway.atmel.com/hudson/job/asf-main-as5-integration-test/19/

Test Result (54 failures / +1)
XMEGAA Empty Project Template with ApplicationBuilder.Application
Builder.UTILITY - XMEGA compiler driver


Other job result  can be found here :
http://norvm-tools-m.norway.atmel.com/hudson/job/asf-main-contents-linux/14/
http://norvm-tools-m.norway.atmel.com/hudson/job/asf-main-gcc/85/
http://norvm-tools-m.norway.atmel.com/hudson/job/asf-main-gcc-linux/56/
http://norvm-tools-m.norway.atmel.com/hudson/job/asf-main-iar/56/