Bug 3010 - Problem: I cannot create a empty project with this controller ATSAM3S4B without errors
: Problem: I cannot create a empty project with this controller ATSAM3S4B witho...
Status: RESOLVED DUPLICATE of bug 2900
Product: Atmel Software Framework
build system
: v3.5.x
: All Standalone
: normal priority major (vote)
: ---
Assigned To: ASF Maintainers
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-02-07 12:12 CET by Nils Feldkämper
Modified: 2013-02-07 14:38 CET (History)
2 users (show)

See Also:
Public Description:
Development Branch:
Whiteboard:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nils Feldkämper 2013-02-07 12:12:32 CET
Hi, 
i have a problem to compile a empty project for "ATSAM3S4B". No Hardware is
connected.

I get 17 errors from "startup_sam3s.c" and "collect2.exe" like:

1: undefined reference to '_srelocate'
2: undefined reference to '_szero'
3: undefined reference to '_sfixed'
4: undefined reference to '_erelocate'
....
17: ld returned 1 exit status


Software:
Atmelstudio 6 SP2 (1996)
ASF 3.5
Windows 7 64bit


It ist a bug or a local problem ?
Comment 1 Nils Feldkämper 2013-02-07 13:47:22 CET
(In reply to comment #0)

We fixed this problem:

Add to Toolchain->Arm/GNU Linker ->Libraries-> Lib search path this:

C:\Program Files (x86)\Atmel\Atmel Studio
6.0\extensions\Atmel\ARMGCC\3.3.1.128\ARMSupportFiles\Device\ATMEL\sam3s\source\as_gcc

and under Toolchain->Arm/GNU Linker ->Miscellanesous add this in front of the
linker flags:

-Tsam3s4b_flash.ld
Comment 2 Cyrille Boulanger 2013-02-07 13:57:50 CET
(In reply to comment #1)
Hi Nils,

Good job, it is a bug indeed, thanks for reporting. This is a known issue
(already reported in bug2900) which I believe has been fixed. The fix should be
available in the next Studio release. In the meantime, as a workaround and as
you already found out, you may try to explicitly set, in the project settings,
the SAM3S4B GCC linker script found in the ASF (in the src/asf folder it should
be under sam/utils/linker_scripts/sam3s/sam3s4/gcc).

*** This bug has been marked as a duplicate of bug 2900 ***
Comment 3 Nils Feldkämper 2013-02-07 14:38:53 CET
(In reply to comment #2)

Ok, thanks for you answer.


We have solved (not perfekt) the problem to implement this path. There is no
gcc version number in the path.
$(ToolchainDir)\..\..\ARMSupportFiles\Device\ATMEL\sam3s\source\as_gcc


At Last we try the "CMSIS Update from Atmel". The function copy the linker
files in the project folder. After that we must delete the src  from cmsis dir.
Then it worked perfekt.