Bug 3544 - wrong timing when using delay routines
: wrong timing when using delay routines
Status: RESOLVED WORKSFORME
Product: Atmel Software Framework
common
: v3.7.x
: Other Standalone
: normal priority normal (vote)
: ---
Assigned To: ASF Maintainers
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-03-21 11:12 CET by Korstiaan
Modified: 2015-04-03 14:13 CEST (History)
1 user (show)

See Also:
Public Description:
Development Branch:
Whiteboard:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Korstiaan 2015-03-21 11:12:47 CET
Hi,

If you use the delay routines, in avr studio 6.2/ ASF 3.22.0, the timing is
wrong (about 1,5 times too slow).

Seems to be because of wrong selection of GCC compiler.

Workaround is by adding the symbol __DELAY_CYCLE_INTRINSICS__

Then the timing is ok.

(From file: ... \src\ASF\common\services\delay\xmega\cycle_counter.h(93):#if
!defined(__DELAY_CYCLE_INTRINSICS__)

Please solve in future releases.


Korstiaan
Comment 1 zheng wang 2015-04-03 10:04:20 CEST
I think you also request a design support.
ASFP-5226 has been created for this.
Comment 2 Korstiaan 2015-04-03 14:12:35 CEST
Hi,

Correct.
ASF bug has been confirmed and I'm waiting at a fix in future release(s).

Korstiaan